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Content

§ Standard Office Tools are very commonly used, like
• Text Processing Word, Pages, openoffice, libreoffice,..
• Presentation Making PowerPoint, Keynote
• Spreadsheet Excel, Numbers

§ Many of us 'know' how to use them, but
• We never really learned systematically (mostly...)
• Knowledge is on a superficial, ‘random’ level
• We may not know some useful tricks / commands / methods

§ In this lecture, I want to show a few things that I know.
• I am not a real expert, but ‘heavy’ every day user, so I have a 

prejudice of what is important...
• Please tell us your tricks!
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Goals

§ Be more efficient in working
§ Get better results / nicer documents
§ Be a bit more professional . For instance when you give 

your document to others.
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Which Tools

§ There are plenty of tools out there in the Windows / iOS / 
Linux worlds

§ I cannot cover all (I do not know all)

§ Many people probably (still) use Windows suite
• Therefore I will restrict on this
• Problem: Even here there are significantly different versions.... 

Sorry!

§ Many concepts are similar everywhere
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EXCEL



Excel: Misc

§ Delete unused sheets!
• (Right click - delete)

§ Give sheets a good name!
• Right click - rename
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Excel: Viewing Things

§ Make columns / rows invisible
• Hide temporary results
• Makes table more readable

§ To show columns again:
• Select group → Right Mouse
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Excel: Adding a ‘button’ to show/hide columns

§ You can ‘group’ columns in the ‘Daten’ Tab
§ This creates a + / - button to open / close the group

9Office Tools (c) Peter Fischer



Excel: Viewing Things

§ Split the screen:
• Allows to view distant parts

• To cancel, slide separation line back again
§ Works in x and y:
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Excel: Absolute & Relative Expressions

§ Field references can be
• relative (A3) or
• absolute in x ($A3) or in y (A$3)
• When the cursor is in the formula field,

F4 toggles the various possibilities
§ Difference relative / absolute mainly visible when copying

§ For some functions, you can use ranges, e.g.: (A1:A3)
• This is better (&faster) than picking the cells, because the range 

is automatically extended @ insertion
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Excel: Highlight of Fields

§ A nice feature is the conditional formatting of fields:

§ There are many possibilities:
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Excel Exercise: Desired Output

§ Your sheet should look similar to this:
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Excel: Data Export

§ Data can be exported as ‘comma separated values’ (csv)

§ Exported data can be plotted in different tool
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Excel: Data Import

§ csv files can be read in easily
• separator symbol can be selected in dialog
• Position in sheet can be fixed
• Titles ... can be taken from file

§ Useful to read in computer generated data
• Better use a good data processing / plotting tool like root, 

gnuplot, ...
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‘Hacking’ .xlsx files

§ Excel’s .xlsx files are ziped XML files (with a folder structure)
• Just rename the .xlsx to .zip and un-zip
• They can then (in principle) be edited by hand!

But structures is complicated…
• This also allows ‘automatic’ generation of Excel content
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More hints from YOU ?

§ ???
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POWERPOINT



PowerPoint: Settings

§ Main setting menu is hidden (in my version...)

§ Very useful: Add buttons for special functions to menu bar

21Office Tools (c) Peter Fischer



PowerPoint: Slide Master & Layouts

§ Most Important:
Use Slide Master for formatting!!!!
• Format is identical on all slides
• Things can be changed later on all slides

• Layouts cannot be deleted when they are used
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‘Master’:
- Things that are visible on all   

pages
- Title and footer template

‘Layout’:
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- Can have additional place

holders



PowerPoint: Page / Title / Footer

§ There are special objects in the Master / Layout:
• Page number
• Date
• Footer text – Can be set later in Insert → Footer/Header menu
• Main text field

§ Right-click on the Master to Add there fields!
§ In the Layouts

• Check the boxes to add Title / Footer 
• Add place holder / text

§ This is big mess.
It never works as expected!
• Must play around to find out!
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PowerPoint: Page / Title / Footer

§ To make these visible on the real slides, must turn them on 
in menu Insert → Footer/Header

• This information often gets lost... Must repeat this step often...
• Button ‘für alle übernehmen’ does not work reliably...
• Try to select all slides, turn footer off, then on again
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PowerPoint: Major Master Problems

§ The Master / Layout implementation is ‘special’ (buggy ?)
• When changing the Master (title,...), the layouts are not 

updated. Must turn ‘title’ off and back on again
• For the footer/ data, must delete them and check box again
• When Layouts are changed, effect is not always visible on 

slides. Must ‘zurücksetzen’ the layout.

• Unfortunately, this clears all special formatting on the page 
(bold, slanted, indices, rulers,...)

• This does not always help: Sometimes must delete the 
footer/date/page and insert them again (see previous slide)...

§ Must play around until it works out..
§ But: It’s really worthwhile!
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PowerPoint: Importing Slides

§ When copying slides from another PowerPoint file, the 
Mater & Layouts are imported
• But colours etc. could be converted to another ‘theme’ (I did not 

talk about themes, I do not use them)

§ You must assign one of ‘your’ Layouts to the new slides 
and possibly re-shuffle things
• May need to change language
• Some ‘old’ footers may be left over
• May need to delete and re-activate footers

§ I then always delete the ‘foreign’ Master & Layouts to keep 
the file clean.
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PowerPoint: Spell Checking

§ Text can be checked
§ Must set the language!

§ Modification is only valid for selected text!
§ Selection ‘Standard’ sets language for new text fields

§ Unfortunately, default language used is not stored in 
document, but is a property of PowerPoint
• When editing an English document after a German document, 

must change language preference back and forth....
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PowerPoint: Formatting Text Fields

§ Text Fields can be formatted via
• Menu bar / commands
• Properties / context menu (right mouse)

§ Both not really consistent! More features in context menu!

§ Advice: rectangles with text are more easy to scale & align.. 
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PowerPoint: Ruler

§ Make the ruler visible: View→Ruler or Right-Mouse on page
§ Ruler input acts on selected cells only!
§ Various types of tabulators (select @ top left)

• Indent
• Start of line
• Left aligned
• Centred
• Right aligned

§ Example: some text aligned
and the next line

§ Use ruler to align text of deeper text levels in Master/Layout
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PowerPoint: Making Nice Graphics

§ Important: Stay on grid!         (Ansicht→Führungslinien→..
• If you must: Shift-arrows shifts in fine steps, off-grid

§ Take care of line ends!
• Normal lines end as a square,

so that corners are ugly

• Much nicer with rectangle

• or round end
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PowerPoint: Making Nice Graphics

§ Rectangles with round corners look nice:

§ Images with shadow look cool
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PowerPoint: Aligning Things

§ Menu Format → Align has many options to align things

§ Make groups      to align multiple objects (see above)

§ Try to stay on the grid (by stretching shapes to grid)
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PowerPoint: Mixed Stuff

§ Chose page size for either
• Normal Screen Aspect Ratio (as used in most beamers)
• Wide Aspect Ratio (used more and more)
• A4 Landscape (if you mainly intend to print..)

§ Never (never !) change the page size once fixed!!!
• This will stretch all figures to off-grid positions → modifications 

become ugly
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PowerPoint: During the Presentation

§ Start slides from #1 F5
§ Start from open slide Shift-F5
§ Turn Screen to White: Press ‘W’ – any key to quit
§ Turn Screen to Black: Press ‘B’  – any key to quit

§ Jump to slide #n page number + ⟨Ret⟩
( or G + number +  ⟨Ret⟩)

• Remember page so that you can jump back!
§ Alternative (but uncool): Right mouse → goto slide...

§ Mark something on slides: Right mouse → pointer → pen
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PowerPoint: Slide Notes

§ You can add notes to each slide to remind you what you 
want to say
• (Or during development to remember what to put on the slide)

§ You can see the notes during a presentation in a dual 
screen mode (need two monitors as extended desktop)
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PowerPoint: LaTeX formulae on slides: IguanaTex

§ There is a free tool to set formula in PowerPoint with LaTeX
§ https://www.jonathanleroux.org/software/iguanatex/ 

1. Run installer
2. Install in PowerPoint 2007:

• Open PowerPoint
• Click Office button → PowerPoint Options
• Click the Add-ins tab
• Choose PowerPoint Add-ins (bottom drop down), Click Go To...
• Choose Add New.
• Select the file IguanaTex.ppa from your install directory
• Click on Close (must allow to activate macros)

§ You obviously must have a valid installation of Latex, for 
instance  MikTeX from http://miktex.org
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PowerPoint: Using IguanaTex

§ PowerPoint 2007:
• Open any presentation
• Choose New Latex Equation from the Add-ins tab.
• Make sure all LaTeX plugins are installed

• Use the ‘Debug’ box to find out..

• To change an equation after it has been rendered, select the 
equation and then choose Edit Latex Equation from the Add-in 
menu.
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More hints from YOU ?

§ ???
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WORD



Word: Most important: Styles

§ Use style files !
§ Put ALL formatting (spacing between paragraphs, 

centering, font, font sizes,...) into style files

§ Use Heading styles (level 1,2,3...) for your headings
• This allows generation of a table on contents...
• You can modify the style

§ Styles can depend on each other
• All are derived from ‘standard’

§ Adjust distance to/from next/previous paragraph

§ Take this serious!
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Word: Frames & Background

§ Frames under Text (Header, Footer) looks nice
§ In Format definition:

• Change → Format → Frame → Shadow
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Word: Numbering of Pictures / ...

§ Add a graphics
§ Right-click on picture:

§ You can also create a new Label Type (‘Abb. #’) 
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Word: Adding a Cross Reference

§ In Menu ‘Verweise’, chose ‘Querverweis einfügen’
§ Chose the type
§ Chose what you want to include

• Only category & number, or also text
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Word: WaterMark

§ Useful for preliminary / confidential / texts...
§ Page Layout → Watermark →User Defined
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Word: Change Tracking

§ When working with colleagues, may want to track changes
§ Turn feature on in Überprüfen → Änderungen verfolgen

• May want to turn on side display
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Word: Checking Modifications

§ Turn on ‘Überarbeitungsfenster’

§ Select change and accept of reject
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Hints

§ Turn on the special character display

§ Use non breakable space (ctrl-shift-space) to separate 
numbers from units etc.

§ Shift-Return Adds a Line-Feed without starting a new 
Paragraph

§ Transfer format with the ‘copy format’ button

§ Learn a few short-cut: index = ctrl +, exponent = ctrl shift +
• Search for ‘Tastenkombinationen’ in (lousy) help system 
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More hints from YOU ?

§ ???
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